martes, 28 de junio de 2011

El misterioso caso de EIGRP y la MTU

Me pasa constantemente que cuando estoy leyendo determinadas publicaciones de Cisco Press (incluso del mismo autor) aparecen contradicciones entre diversos enunciados.

Quizás la más llamativa sea la eterna pregunta de si el protocolo de ruteo EIGRP utiliza o no la MTU de las interfaces para calcular las métricas.

Veamos los materiales de referencia que se contradicen:


Libro: CCNA ICND2 Official Exam Certification Guide (CCNA Exams 640-816 and 640-802), Second Edition
Autor:
Wendell Odom - CCIE No. 1624

Editorial:
Cisco Press

Fecha de publicación:
30 de Agosto del 2007

ISBN-10:
1-58720-181-X

ISBN-13:
978-1-58720-181-3

Capturo un comentario del texto:

Traduzco:

"... Nota: Documentos y libros antiguos solían expresar que EIGRP, y su predecesor, IGRP, ademas podrían usar la MTU como parte de la métrica, pero la MTU no puede ser usada y nunca fue considerada como parte del cálculo. "
Vamos a otro...

Libro: CCIE Routing and Switching Exam Certification Guide, Fourth Edition
Autores:
Wendell Odom - CCIE No. 1624; Rus Healy - CCIE No. 15025; Denise Donohue - CCIE No. 9566

Editorial:
Cisco Press

Fecha de Publicación:
08 de Diciembre del 2009

ISBN-10:
1-58705-980-0

ISBN-13:
978-1-58705-980-3

Capturo el comentario correspondiente...

Traduzco:

"... Seteando los valores K correctos en el comando metric weights, EIGRP puede además considerar la carga de los enlaces, la confiabilidad y la MTU ..."
Como le estuve dando muchas vueltas a este tema, voy a armar un lab con equipos para sacarme la duda...


Topología del lab:



En este simple ejemplo vamos a publicar dos redes con enlaces intermedios de diferentes MTU y veremos como R1 calcula las métricas de cada una.


Configuraciones Iniciales:

R1:

hostname R1
!
interface FastEthernet0/0
 description Enlace a R2
 ip address 192.168.0.1 255.255.255.252
 bandwidth 10000
!
router eigrp 8
 metric weights 0 1 1 1 1 1
 network 192.168.0.0
 no auto-summary
 eigrp router-id 1.1.1.1
!

R2:

hostname R2
!
interface FastEthernet0/0
 description Enlace a R1
 ip address 192.168.0.2 255.255.255.252
 bandwidth 10000
!
interface FastEthernet0/1
 description Enlace a R3
 ip address 192.168.1.1 255.255.255.252
 bandwidth 10000
 ip mtu 1000
!
interface FastEthernet0/2
 description Enlace a R4
 ip address 192.168.1.5 255.255.255.252
 bandwidth 10000
!
router eigrp 8
 metric weights 0 1 1 1 1 1
 network 192.168.0.0
 network 192.168.1.0
 no auto-summary
 eigrp router-id 2.2.2.2
!

R3:

hostname R3
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
 ip mtu 1000
!
interface FastEthernet0/0
 description Enlace a R2
 ip address 192.168.1.2 255.255.255.252
 bandwidth 10000
 ip mtu 1000
!
router eigrp 8
 metric weights 0 1 1 1 1 1
 network 192.168.1.0
 network 192.168.3.0
 no auto-summary
 eigrp router-id 3.3.3.3
!

R4:

hostname R4
!
interface Loopback3
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0
 description Enlace a R2
 ip address 192.168.1.6 255.255.255.252
 bandwidth 10000
!
router eigrp 8
 metric weights 0 1 1 1 1 1
 network 192.168.1.0
 network 192.168.4.0
 no auto-summary
 eigrp router-id 4.4.4.4
!
Ahora vamos a analizar la tabla de ruteo de R1:
R1#show ip route eigrp 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      192.168.1.0/30 is subnetted, 2 subnets
D        192.168.1.0 [90/1203] via 192.168.0.2, 00:00:15, FastEthernet0/0
D        192.168.1.4 [90/1203] via 192.168.0.2, 00:00:15, FastEthernet0/0
D     192.168.3.0/24 [90/1703] via 192.168.0.2, 00:00:15, FastEthernet0/0
D     192.168.4.0/24 [90/1703] via 192.168.0.2, 00:00:15, FastEthernet0/0
Hasta ahora las rutas tienen las mismas métricas a pesar del cambio de MTU, vamos a ver las entradas de cada red en la tabla de topología:
R1#sh ip eigrp topology 192.168.3.0
EIGRP-IPv4 Topology Entry for AS(8)/ID(1.1.1.1) for 192.168.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 1703
  Descriptor Blocks:
  192.168.0.2 (FastEthernet0/0), from 192.168.0.2, Send flag is 0x0
      Composite metric is (1703/1603), route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 7000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1000
        Hop count is 2
        Originating router is 3.3.3.3

R1#show ip eigrp topology 192.168.4.0
EIGRP-IPv4 Topology Entry for AS(8)/ID(1.1.1.1) for 192.168.4.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 1703
  Descriptor Blocks:
  192.168.0.2 (FastEthernet0/0), from 192.168.0.2, Send flag is 0x0
      Composite metric is (1703/1603), route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 7000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2
        Originating router is 4.4.4.4

Evidentemente y a pesar que con el metric weights obligamos a que EIGRP calcule todas las variables posibles, el MTU  de los enlaces no interviene en el cálculo de la métrica.

Nos vemos en la próxima!

2 comentarios:

Anónimo dijo...

Muy bueno! Yo era otro con la duda...

fabian monge dijo...

Nota: algunos libros sobre EIGRP pueden afirmar incorrectamente que la Unidad máxima de transmisión (MTU) es una de las métricas utilizadas por EIGRP. MTU no es una métrica utilizada por EIGRP. MTU está incluida en las actualizaciones de enrutamiento pero no se utiliza para determinar la métrica de enrutamiento.

Publicar un comentario